101 Cooking For Two - Everyday Recipes for Two: Printing issues

Saturday, August 20, 2011

Printing issues

My offering of an apology... Sorry about that
The print function on many posts does not work anymore. What did work, no longer works. I suspect a change in Blogger programming which means there is nothing I can do to fix the cause. I'm in the process of working back through the posts manually and creating a print page and linking it correctly to the print button. In the mean time, simply highlight the area you want to print and go to file menu. To print... then Page range and then choose "selection". This instructions are for Firefox but are approximately correct for all browsers. Sorry for the inconvenience.

UPDATE: Please see the first comment below from Dulce Dough for "the fix". Excellent. Thanks to Dulce Dough.  Go visit her site and give her a +1 and click an ad.


Final and last update: I give up... I'm in the progress of creating "print files" on Google sites and connecting them to the print function.
Updated

September 14 2011

DrDan

Labels:

12 Comments:

At August 20, 2011 at 7:06 PM , Blogger Dulce Dough said...

I noticed that my newer recipes don't print, and compared them to the older ones that do print. The following code was missing:

onclick="printDiv(); return false;"

One of the recipes also had some other code missing, but all the others were only missing the above. You can compare your recipes that do print to see where it needs to be added.

 
At August 20, 2011 at 10:16 PM , Blogger Dr Dan said...

YOU ARE SO RIGHT!!!!!!!! (that is the first time I have shouted in a long time.) Thanks so much. I have spent the last two hours scanning about 200 posts and most of the lasts 2 months were broken as you discribe. The previous 2 months about half and randoms ones before that. I have seen people "printing" these on statcounter but didn't realize there was a problem.

 
At August 21, 2011 at 7:56 AM , Blogger Inspired by eRecipeCards said...

Arn't bloggers the best! One of us knows everything!

 
At August 21, 2011 at 8:36 PM , Blogger Dulce Dough said...

Glad I could help! And thank you as well, because if I hadn't read your post I would not have realized that mine had quit working and wouldn't have checked them!

 
At August 21, 2011 at 8:40 PM , Blogger Dr Dan said...

This comment has been removed by the author.

 
At August 21, 2011 at 8:42 PM , Blogger Dr Dan said...

I played around with comparing code for several hours but was hung up on the draft.blogger vs www.blogger stuff. If I had just looked a little farther.

I did post your solution on the Recipewiz Facebook page... I gave you full credit. :)

Again, thanks.

 
At August 25, 2011 at 10:14 AM , Blogger Dulce Dough said...

I'm still having problems. Even after entering the missing code Blogger seems to remove it. Last night I posted a new recipe that had the same print problem. I added the missing code, and it worked. But this morning the print function didn't work and I had to add the missing code in again. When I checked older recipes, they all seemed to work OK, but when I looked at the HTML the same piece of code was missing. I don't know why they still printed w/o the code but the new one wouldn't. BTW when I copy the code from the Recipe Wiz, the onclick="printDiv(); return false;" is included, so it is Blogger that is changing it for some reason.

 
At August 25, 2011 at 7:53 PM , Blogger Dr Dan said...

The plot thickens. I looked back through about 10 posts. They all work and none now have the code even though I put it in manually. If I had a clue how it worked I could comment more. I will check into the programming in the next few days. I do have a computer science degree (Many years ago). I guess it is time to learn HTML more...

 
At August 25, 2011 at 10:31 PM , Blogger Dr Dan said...

My most recient post was correct going into Blogger from RecipeWiz. But would not print. I checked and the code was missing. I add the code and it now works fine. I did check the code and it is correct for the moment. I wonder if it's that "new look" draft blogger that I have been using most of the time the last month or so... I have several new posts coming in the next couple of days so will experement some.

 
At August 27, 2011 at 7:55 AM , Blogger Dr Dan said...

An update. The appears to be two versions of draft.blogger that I use to post. The "old version" is dark blue on top and I have of hot link to that and somewhat prefer that editor so I did my last post in it. The code was correct from RecipeWiz and the code was removed and the print function did not work. I went back and added the code in the same editor and it disappeared again when published.

I then opened the "new version" of Blogger in Draft (the one in pale blue), corrected the code, published. The code remained and it works. I think we at least have an idea of the cause. Now why some without the code work, I have no clue.

I did use the "new version" a few days ago when I did the initial corrections.

 
At August 28, 2011 at 8:57 AM , Blogger Dr Dan said...

I did today's post entirely in the newer draft blogger and the same thing happened with the code disappearing. I added it back in in the old version and it is now there and works.

 
At August 29, 2011 at 7:34 PM , Blogger Dr Dan said...

It appears the code will remain if the post is saved from the HTML editing window and correct at that point but not if saved from the compose window. This occur in both Blogger and Draft Blogger.

If you go back a edit a post (example: need to correct say a misspelling) the code will be gone when you open up the post and will need to be fixed again. This is what I believe is correct after playing with it for several hours.

 

Post a Comment

Did you enjoy the post or have a question? Please leave a comment or ask away, provide info on how you liked something, etc. Note that spam, rude comments or comments with random links will all be deleted.

Subscribe to Post Comments [Atom]

<< Home